Skip to content

6 febrero, 2008

4

PHPEclipse en Ubuntu

Como comentaba en el post anterior uso ubuntu en mi lap por lo cual me dispuse a instalar diferentes editores php, como gPHPEdit, Quanta Plus, JEdit, Screem entre muchos otros, pero no más no me terminaban de convencer, al final me he quedado con PHPEclipse, un plugin para eclipse.

Al principio puede parecer media turbia la instalación, pero la realidad es otra.

Ya teniendo instalada correctamente la máquina virtual de Java (incluso se puede instalar con automatix para los que no se quieran meter en problemas), procedemos a la instalación de eclipse.

  • Descargamos el eclipse de http://www.eclipse.org/downloads/ en nuestro caso el llamado Eclipse IDE for Java Developers.
  • Descomprimimos el archivo, si lo haces desde el Nautilus, click derecho extraer y listo :)
  • Coloca la carpeta descomprimida donde quieras alojar el programa, yo la he puesto en /opt/ (necesitas permisos de root para poder mover la carpeta). Si lo haces en la consola #sudo mv /ruta/del/eclipse /opt/
  • Descargas el plugin PHPEclipse AQUÍ en mi caso el phpeclipse-1.1.8
  • De igual manera que con el eclipse, lo descomprimimos, pero ahora la carpeta que obtenemos al descomprimir el archivo la colocamos en la ruta de plugins de nuestro eclipse, en mi caso en /opt/eclipse/plugins/
  • Ejecutamos eclipse (doble click) al archivo llamado “eclipse” que se encuentra en nuestra ruta de instalación (/opt/eclipse/)

Si todo va bien ya tenemos ejecutándose nuestro eclipse, lo siguiente sería terminar de instalar el PHPEclipse, para ello hacemos lo siguiente.

  • Nos dirigimos a menú Help -> Software Updates -> Find and Install …
  • Aparecerá una ventana con dos opciones, escogemos “Search for new feactures to install” y damos click en Next
  • Damos click al botón “New Remote Site …”
  • En la ventana que nos aparece hay dos campos, uno llamado Name y el otro URL. En name ponemos “PHPEclipse Nightly” y en URL “http://update.phpeclipse.net/update/nightly” (ambos campos sin las comillas)
  • Click en Next.
  • Asegurate que esté seleccionada la opción PHPEclipse Nightly y damos click en Finish.

Después de instalar nuestro plugin necesitamos activar la perspectiva, para eso hacemos lo siguiente

  • Menu Window -> Open Perspective -> Other -> Select PHP -> Ok.

Y listo a disfrutar de nuestro PHPEclipse y a programar :)

Por cierto para Windows es prácticamente el mismo procedimiento, no creo que tengas problemas con ello.

Se me olvidaba si tienes instalado un servidor xampp, PHPEclipse lo integra y así puedes testear tus scripts desde el mismo eclipse sin necesidad de un navegador web :P.

Salu2

4 Comments Post a comment
  1. oct 8 2008

    Hola amigo realice todos los pasos pero cada vez k intento abrir un archivo PHP me dice que ha ocurrido un error que revise el LOG

    como hago eso y como se podria solucionar :'(

  2. blackeye
    feb 12 2009

    me ha ido muy bien.
    Gracias

  3. abr 12 2009

    Por cierto:

    Yo tengo un laptop Pavillion dv5 corriendo con una Ubuntu 8.10, en la que he instalado un Eclipse 3.2.

    En cuanto a los infalibles pasos que has dado, para instalar el Plug-in PHPEclipse, decir que para mi, NO HA SIDO NECESARIO el paso en el que pareces indicar hay que bajarse el paquete phpeclipse-1.1.8, y copiar la carpeta comprimida en /opt/eclipse/plugins.

    SALTÁNDOME dicho paso, y procediendo, directamente, a añadir el repositorio que indicas mas abajo,

    http://update.phpeclipse.net/update/nightly

    Al utilizar dicho repositorio, todo se me instala, desde Internet, de forma totalmente automática.

    En cuanto a la Fedora 10, que también tengo instalada en dicho laptop (y que, por cierto, es la que yo personalmente utilizo por preferencia, el Ubuntu, que lo tengo en una “pendrive”, lo utilizo como “banco de pruebas” debido a que en mi trabajo tengo Ubuntu…), me funciona también a las mil maravillas.
    La diferencia:

    En Ubuntu, el Eclipse que se me instala es el 3.2, mientras que en mi Fedora, se me instala el flamante y ultra-moderno 3.4.
    Por consiguiente, en Ubuntu, el paquete que se me instalará, será, supongo, el phpeclipse-1.1.8 (como pareces haber indicado…) o alguno sobre la altura, mientras que en mi versión de Eclipse de Fedora (la 3.4.3…), el paquete será (si es que está actualizado a la última, y si no me equivoco…), el phpeclipse-1.2.1, o superior….

    Pero…..
    ¡Muchas gracias! ya que, si no fuese por esto, con el repositorio de la propia página de PHPEclipse

    http://update.phpeclipse.net/update/stable/1.1.x

    Que, con Fedora (y mi versión de Eclipse 3.4….) me funcionó, resultase que con Ubuntu, y su “versión 3.2″…, como que me daba “fallos de incompatibilidad”, a la hora de tratar de instalarlo….

    Saludos

  4. Laura
    abr 13 2009

    MUCHISIMAS GRACIAS!!!!!!!!!!!!!!!!!!!!!!!!!!!1

Share your thoughts, post a comment.

(required)
(required)

Note: HTML is allowed. Your email address will never be published.

Subscribe to comments